описание

Описание сервера "Центр тестирования" ver 1.00

Назначение сервера - Производить интерактивное тестирование учащихся учебных заведений с помощью интернет технологии (web).Система разрабатывалась на администрирования даже не подготовленного пользователя.

Оглавление:

1. Описание функций и принципа работы сервера “Центра тестирования”
2.Рабочее место администратора сервера
 | 2.1. "Пароль"
 | 2.2. "Настройка"
 | 2.3. "Библиотека"
 | 2.4. “Библиотека::Редактирование”
 | 2.5. “Редактировать шаблоны”
 | 2.6. “Редактировать шаблоны ::Редактировать”
 | 2.7. “Редактирование новостей”
 | 2.8. “Редактирование новостей::Редактирование”
 | 2.9. “Настройка акселерации”
 | 2.10. “Тесты::Список тем”
 | 2.11. “Тесты::Список тем::Редактирование темы”
 | 2.12. “Тесты::Список тем::Редактирование темы::Редактирование вопросов”
 | 2.13. “Тесты::Список тем::Редактирование темы::Редактирование вопросов::Вопрос”
 | 2.14. “Ученики::Список групп”
 | 2.15. “Ученики::Список групп::Ученики”
 | 2.16. “Ученики::Список групп::Ученики::Ученик”
 | 2.17. “Ученики::Список групп::Ученики::Ученик::Письмо формы регистрации”
3.Рабочее место тестируемого
 | 3.1. “Процесс тестирования”


2.1. "Пароль" - настройка пароля на доступ
В данном разделе вы имеете возможность изменить пароль на доступ (для администратора)
1. Логин - Текущий логин администратора
2. Пароль - Текущий пароль администратора
3. Новый логин - Новый логин администратора
4. Новый пароль - Новый пароль администратора
5. Повтор нового пароля - Повтор нового пароля администратора


2.2. "Настройка"
В данном разделе вы имеете возможность изменить настройки работы сервера
Таблица обозначения форматов даты и времени
d | - показывает день в виде числа без предшествующего нуля (значения 1-31)
dd | - показывает день в виде числа c предшествующим нулем (значения 01-31)
ddd | - показывает день недели в сокращенном виде (воскр-суб)
dddd | - показывает день недели в полном виде (воскресенье-суббота)
m | - показывает месяц в виде числа без предшествующего нуля (значения 1-12)
mm | - показывает месяц в виде числа c предшествующим нулем (значения 01-12)
mmm | - показывает месяц в сокращенном виде (янв-дек)
mmmm | - показывает месяц в полном виде (январь-декабрь)
yy | - показывает год в виде числа из двух цифр (значения 00-99)
yyyy | - показывает год в виде числа из четырех цифр (значения 0000-9999)
h | - показывает время в часах без предшествующего нуля (значения 0-23)
hh | - показывает время в часах с предшествующим нулем (значения 00-23)
n | - показывает минуты без предшествующего нуля (значения 0-59)
nn | - показывает минуты с предшествующим нулем (значения 00-59)
s | - показывает секунды без предшествующего нуля (значения 0-59)
ss | - показывает секунды с предшествующим нулем (значения 00-59)

1. Относительный путь до html шаблонов
2. Сетевой путь до сервера (не до шлюза)
3. Web администратора сервера или фирмы-владельца -Данный адрес автоматически вставляется в сноски страницы.
4. E-mail адрес администратора сервера - Данный адрес используется при вызове обратной связи и автоматически вставляется в сноски страницы
5. SMTP адрес - адрес SMTP сервер вашего (см. пункт №4) e-mail
6. Номер порта e-mail сервера - номер порта SMTP сервера вашего (см. пункт №4) e-mail
7. Приоритет выполнения сервера - Для коррекции скорости работы сервера предусмотрена сетка привилегий выполнения.
8. Формат "короткого" обозначения даты - обозначение короткого формата даты. Используется для обозначения даты. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
9. Формат "короткого" обозначения даты - обозначение короткого формата даты. Используется для обозначения даты на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
10. Разделитель времени - символ разделителя времени. К примеру - 12:12 символ ":" является разделителем.
11. Разделитель даты - символ разделителя даты. К примеру - 12.10.2001 символ "." является разделителем.
12. Формат "короткого" времени - обозначение короткого формата времени. Используется для обозначения времени на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
13. Формат "длинного" времени - обозначение длинного формата времени. Используется для обозначения времени на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"


2.3. "Библиотека"
Редактирование списка книг в библиотеке

1. Редактировать - Редактировать пункт в библиотеке
2. Удалить - Удалить "книгу" из списка.
3. Добавить - Добавить книгу в список книг.
4. Дата - Дата поступления книги в библиотеку
5. Ссылка и наименование книги - Наименование и сетевая ссылка к файлу (архиву) книги.
6. № п/п-Номер книги по порядку от большего к меньшему. Тем самым самые "свежие" книги будут в начале списка.

Вставка списка книг (вставка библиотеки) производится при помощи JavaScript. Блок:
<script language="JavaScript" src="cgi-bin/test.cgi?status=bibleo"></script>


2.4. “Библиотека::Редактирование”
Редактирование пункта в библиотеке

1. Дата - Дата поступления книги в библиотеку. Формат даты указан. Для изменения формата даты см. 2.2. “Настройка”
2. Наименование - Наименование книги.
3. Ссылка - сетевая ссылка (не забудьте ввести полный формат пути "http://www.server.com/dir/file") Сетевой путь сделан дабы не загружать сервер промежуточной работой.


2.5. “Редактировать шаблоны”
Интерактивное редактирование html шаблонов

1. Шаблоны для всех (общие) - список общих шаблонов.

От создателя шлюза: Как говорилось позже вся система (сервер) построен на шаблонной схеме - это значит что каждая страница представлена в виде шаблона (html страницы с специальными врезками) который динамически погружается, изменяется и "показывается" посетителю. В шаблонной технологии очень просто изменить дизайн любого шаблона (страницы) сервера не изменяя сам код шлюза. Однако для изменения шаблонов необходимо знать основы html языка и знать структуру сервера и бегло ориентироваться в спец тегах сервера. Для создания своего дизайна сервер обратитесь к профессионалам или фирме поставившего данный сервер. www.newtone.kz


2.6. “Редактировать шаблоны ::Редактировать”
Редактирование шаблона

1. Имя файла - Имя редактируемого файла
2. Размер файла - размер редактируемого файла. В байтах
3. Текст шаблона

От создателя шлюза: Для изменения шаблоны скопируйте в буфер содержимое текста шаблона в редактор html (к примеру FrontPage). Посте изменения новый текст через буфер обмена скопируйте в текст шаблона и сохраните (кнопочка "Сохранить").


2.7. “Редактирование новостей”
Редактирование списка новостей
1. Редактирование-Редактирование новости
2. Удалить - Удаление новости
3. Добавить - Добавить новость.
4. Дата - Дата новости. Данная дата будет выделена жирным "цветом"
5. Новость - Список новостей. Использование тегов html запрещено. При вставке тегов они будут рассматриваться как текст
6. № п/п - Номер по порядку от большего к меньшему. тем самым самые свежие новости всегда будут в начале перечня.
7. Сколько пунктов показать при предварительном показе - Сколько пунктов новостей показать при предварительном показе.

Вставка блока предварительного просмотра новостей производится с помощью JavaScript. Блок:
<script language="JavaScript" src="cgi-bin/test.cgi?status=news"></script> Количество пунктов регулируется в поле "Сколько пунктов показать при предварительном показе" см. №7


2.8. “Редактирование новостей::Редактирование”
Редактирование новости
1. Дата новости -Дата новости. Формат даты сервера представлен. Для изменения формата даты см. 2.2. “Настройка”
2. Новость - Сама новость.


2.9. “Настройка акселерации”
Настройка движка акселерации сервера

1. Упаковывать показываемые страницы стандартом GZip - Включить упаковку стандартом GZip Encoding. Увеличение скорость загрузки страниц от 2 до 16 раз (в некоторых случаях и до 20(!!) раз)
2. Удалять начальные пробелы в файлах html. - Очищает html от ненужных символов (первых пробелов) которые остаются от редактора html файлов. Уменьшение размера страницы от 5 до 40%.
3. Командная строка упаковки. - Вы имеете возможность самостоятельно настроить командную строку упаковки. Оптимальный вариант (скорость/процент упаковки) w3, Максимальная упаковка w9 но очень медленная, авто определение метода упаковки - w


2.10. “Тесты::Список тем”
Редактирование тестов - темы тестов

1. Редактирование - редактирование теста
2. Удалять - удалить тест
3. Добавить - добавить новый тест
4. Количество вопросов - Количество вопросов в тесте
5. Наименование - Список наименований тестов
6. Номер по порядку - от большего к меньшему


2.11. “Тесты::Список тем::Редактирование темы”
Редактирование теста

1. Название - Название теста
2. E-mail адрес куратора темы - E-mail адрес куратора темы на который будут отправлены результаты тестов по данному вопросу (если в учетной записи тестируемого будет включен параметр "Отправка результата тестирования на e-mail куратору темы")
3. Адрес e-mail сервера - Адрес SMTP сервера
4. Порт e-mail сервера - Порт SMTPl сервера
5. Сколько вопросов показать - К примеру, общее количество вопросов 200, а данный параметр установлен на 50 вопросов. 50 вопросов будут "выбираться" случайным образом. Предусмотрена схема предотвращения повторов вопросов.
6. Тестирование на время - Предусмотрен вариант тестирования на время. Для одного вопроса выделяется x минут (см. №7) Если тестируемый не ответил на вопрос в x минут, ему засчитывается не правильный ответ.
7. Время на тестирование в минутах - Сколько минут давать тестируемому на ответ одного вопроса. См. №6

В данной версия сервер предусмотрена пяти бальная оценочная схема. По вашему выбору может быть произвольная схема (A..F, 1..10, 0%..100% и т.д.)
8. Процент правильного ответа для оценки 1 - Процент правильного ответа для оценки 1
9. Процент правильного ответа для оценки 2 - Процент правильного ответа для оценки 2
10. Процент правильного ответа для оценки 3 - Процент правильного ответа для оценки 3
11. Процент правильного ответа для оценки 4 - Процент правильного ответа для оценки 4
12. Процент правильного ответа для оценки 5 - Процент правильного ответа для оценки 5
13. Редактирование вопросов - Раздел редактирования вопросов


2.12. “Тесты::Список тем::Редактирование темы::Редактирование вопросов”
Редактирование вопросов теста

1. Редактирование - Редактирование вопроса.
2. Удалить - Удалить вопрос
3. Вопрос - Список вопросов. Пользуйтесь навигацией для перехода на другую страницу.
4. № п/п - Номер по порядку. От большего к меньшему.
5. Добавить - Добавить новый вопрос.


2.13. “Тесты::Список тем::Редактирование темы::Редактирование вопросов::Вопрос”
Редактирование вопроса

1. Вопрос - Текст вопроса
2. Бал ответа - Бал ответа - Да (правильный +1 ответ) Нет - (не правильный +0 ответ)
3. Вариант ответа - Текст варианта ответа
4. № п/п - Номер по порядку. От большего к меньшему.
Максимально вариантов может быть 20.


2.14. “Ученики::Список групп”
Редактирование вопроса

1. Редактирование - Редактирование группы тестируемых
2. Удалить - Удалить группу учащихся. Группа должна быть пустой.
3. Добавить - Добавить новую группу
4. Количество учеников - Количество учеников в группе
5. Наименование - Наименование групп учеников
6. № п/п - Номер по порядку. От большего к меньшему.


2.15. “Ученики::Список групп::Ученики”
Редактирование вопроса

1. Редактирование - Редактирование группы тестируемого
2. Удалить - Удалить тестируемого
3. Добавить - Добавить тестируемого
4. Ученики - Список учеников
5. № п/п - Номер по порядку. От большего к меньшему.
6. Наименование группы - Название группы. Для изменения названия группы изменить данное поле и сохраните изменения (кнопочка "Ввод")


2.16. “Ученики::Список групп::Ученики::Ученик”
Редактирование ученика (тестируемого)

1. Ученик - Псевдоним ученика.
2. Фамилия - Фамилия ученика.
3. Имя - Имя ученика.
4. Отчество - Отчество ученика.
5. E-Mail - E-Mail ученика.
6 .Отправка результата тестирования на e-mail куратору темы - Переключатель отправки результата тестирования данного ученика на e-mail куратору темы тестирования
7. Разрешенный тест - Какой тест будет предоставляться для тестирования данного ученика (тестируемого)
8. Вход с паролем? - Если данный параметр включен, тогда для тестирования будет проситься ввести пароль и логин (см. №9, см. №10)
9. Логин - Логин ученика.
10. Логин - Логин ученика.
11. Письмо формы регистрации - Раздел для отправления письма регистрации на e-mail (см.№5) ученика

Используйте пробное тестирование из формы (выделено красным цветом). Так же в поле представлен полный путь для тестирования данного тестируемого.


2.17. “Ученики::Список групп::Ученики::Ученик::Письмо формы регистрации”
Отправка письма-уведомления о регистрации

1. E-mail ученика - E-mail ученика на который будет отправлено письмо
2. Текст - текст письма. Разрешено редактирование


[ <<Назад ] [ в оглавление ] [Далее>>]

3.1. “Процесс тестирования”
Отправка письма-уведомления о регистрации

рис. №1

рис. №2

рис. №3
рис. №4

Процес тестирования начинается с заполнения формы (для примера см. www.newtone.kz) где вводится id номер тестируемого, который он получает от куратора/администратора.
После ввода id, если в настройках тестируемого указан параметр (см. 2.16. “Ученики::Список групп::Ученики::Ученик”) вход с паролем то, вам необходимо ввести свой логин и пароль (см. рис №1). Если пароль и логин введен верно вы попадете в предварительное окно тестирования см. рис №2 в котором указаны ваши личные данные и некоторые параметры. Для начало непосредственно тестирования перейдите на ссылку "Начать тестирование>>"

Само тестирование происходи по методу выбора правильного варианта из списка (см. рис 3). Хотя по желанию учебного заведения схема может быть переделана. Если тестирование происходит с учетом времени на каждый вопрос, над вопросом будет "тикать" часики которые показывают сколько осталось минут,секунд до истечения времени. см. №1 Если вариант не дан в течении времени отведенного на вопрос автоматически засчитывается не верный ответ. Кроме контроля времени на ответ имеется секундомер, который фиксирует, сколько времени уже длится тестирование.

После тестирования тестируемому предоставляется отчет о тестировании (см. рис №4) на котором предоставлены ваши личные данные, количество правильных ответов, оценка и процент правильного ответа. После тестирования куратору темы тестирования отправляется письмо с результатом тестирования тестируемого.


[<<Назад] [в оглавление ] [ Далее>> ]

1. Описание функций и принципа работы сервера “Центра тестирования”
Назначение сервера - Производить интерактивное тестирование учащихся учебных заведений с помощью интернет технологии (web).Система разрабатывалась на администрирования даже не подготовленного пользователя.
Тестирование на сервере происходит по данной схеме:
  1. Будущий тестируемый изъявляет желание протестироваться на определенный материал.
  2. Администратор вводит анкетные данные тестируемого и отправляет идентификационные данные.
  3. Тестируемый тестируется. После тестирования результат тестирования отправляется администратору материала.