описание

Описание сервера "Информационный центр" ver 1.00

Назначение сервера - Автоматизировать ряд задач для сервера учебного заведения (далее убедитесь что не только для учебного заведения)

Оглавление:

1.Рабочее место администратора сервера
 | 1.1. "Пароль" - настройка пароля на доступ
 | 1.2. "Настройка"
 | 1.3. “Редактировать шаблоны”
 | 1.4. “Редактировать шаблоны ::Редактировать”
 | 1.5. “Библиотека”
 | 1.6. “Библиотека::Редактирование”
 | 1.7. “Редактирование новостей”
 | 1.8. “Редактирование новостей::Редактирование”
 | 1.9. “Список прайсов”
 | 1.10. “Список прайсов::Редактирование”
 | 1.11. “Редактирование расписания”
 | 1.12. “Группы::Курсы”
 | 1.13. “Группы::Курсы::Редактирование”


[<<Назад] [ в оглавление ] [ Далее>> ]

1.1. "Пароль" - настройка пароля на доступ
В данном разделе вы имеете возможность изменить пароль на доступ (для администратора)
1. Логин - Текущий логин администратора
2. Пароль - Текущий пароль администратора
3. Новый логин - Новый логин администратора
4. Новый пароль - Новый пароль администратора
5. Повтор нового пароля - Повтор нового пароля администратора


1.2. "Настройка"
В данном разделе вы имеете возможность изменить настройки работы сервера

Таблица обозначения форматов даты и времени
d | - показывает день в виде числа без предшествующего нуля (значения 1-31)
dd | - показывает день в виде числа c предшествующим нулем (значения 01-31)
ddd | - показывает день недели в сокращенном виде (воскр-суб)
dddd | - показывает день недели в полном виде (воскресенье-суббота)
m | - показывает месяц в виде числа без предшествующего нуля (значения 1-12)
mm | - показывает месяц в виде числа c предшествующим нулем (значения 01-12)
mmm | - показывает месяц в сокращенном виде (янв-дек)
mmmm | - показывает месяц в полном виде (январь-декабрь)
yy | - показывает год в виде числа из двух цифр (значения 00-99)
yyyy | - показывает год в виде числа из четырех цифр (значения 0000-9999)
h | - показывает время в часах без предшествующего нуля (значения 0-23)
hh | - показывает время в часах с предшествующим нулем (значения 00-23)
n | - показывает минуты без предшествующего нуля (значения 0-59)
nn | - показывает минуты с предшествующим нулем (значения 00-59)
s | - показывает секунды без предшествующего нуля (значения 0-59)
ss | - показывает секунды с предшествующим нулем (значения 00-59)
1. Относительный путь до html шаблонов
2. Сетевой путь до сервера (не до шлюза)
3. Web администратора сервера или фирмы-владельца -Данный адрес автоматически вставляется в сноски страницы.
4. E-mail адрес администратора сервера - Данный адрес используется при вызове обратной связи и автоматически вставляется в сноски страницы
5. SMTP адрес - адрес SMTP сервер вашего (см. пункт №4) e-mail
6. Номер порта e-mail сервера - номер порта SMTP сервера вашего (см. пункт №4) e-mail
7. Приоритет выполнения сервера - Для коррекции скорости работы сервера предусмотрена сетка привилегий выполнения.
8. Формат "короткого" обозначения даты - обозначение короткого формата даты. Используется для обозначения даты. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
9. Формат "короткого" обозначения даты - обозначение короткого формата даты. Используется для обозначения даты на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
10. Разделитель времени - символ разделителя времени. К примеру - 12:12 символ ":" является разделителем.
11. Разделитель даты - символ разделителя даты. К примеру - 12.10.2001 символ "." является разделителем.
12. Формат "короткого" времени - обозначение короткого формата времени. Используется для обозначения времени на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
13. Формат "длинного" времени - обозначение длинного формата времени. Используется для обозначения времени на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"


1.3. “Редактировать шаблоны”
Интерактивное редактирование html шаблонов

1. Шаблоны для всех (общие) - список общих шаблонов.

От создателя шлюза: Как говорилось позже вся система (сервер) построен на шаблонной схеме - это значит что каждая страница представлена в виде шаблона (html страницы с специальными врезками) который динамически погружается, изменяется и "показывается" посетителю. В шаблонной технологии очень просто изменить дизайн любого шаблона (страницы) сервера не изменяя сам код шлюза. Однако для изменения шаблонов необходимо знать основы html языка и знать структуру сервера и бегло ориентироваться в спец тегах сервера. Для создания своего дизайна сервер обратитесь к профессионалам или фирме поставившего данный сервер. www.newtone.kz


1.4. “Редактировать шаблоны ::Редактировать”
Редактирование шаблона

1. Имя файла - Имя редактируемого файла
2. Размер файла - размер редактируемого файла. В байтах
3. Текст шаблона

От создателя шлюза: Для изменения шаблоны скопируйте в буфер содержимое текста шаблона в редактор html (к примеру FrontPage). Посте изменения новый текст через буфер обмена скопируйте в текст шаблона и сохраните (кнопочка "Сохранить").


1.5. “Библиотека”
Редактирование списка книг в библиотеке

1. Редактировать - Редактировать пункт в библиотеке
2. Удалить - Удалить "книгу" из списка.
3. Добавить - Добавить книгу в список книг.
4. Дата - Дата поступления книги в библиотеку
5. Ссылка и наименование книги - Наименование и сетевая ссылка к файлу (архиву) книги.
6. № п/п-Номер книги по порядку от большего к меньшему. Тем самым самые "свежие" книги будут в начале списка.

Вставка списка книг (вставка библиотеки) производится при помощи JavaScript. Блок:
<script language="JavaScript" src="cgi-bin/inform.cgi?status=bibleo"></script>


1.6. “Библиотека::Редактирование”
Редактирование пункта в библиотеке

1. Дата - Дата поступления книги в библиотеку. Формат даты указан. Для изменения формата даты см. 1.2. “Настройка”
2. Наименование - Наименование книги.
3. Ссылка - сетевая сслыка (не забудьте ввести полный формат пути "http://www.server.com/dir/file") Сетевой путь сделан дабы не загружать сервер промежуточной работой.


1.7. “Редактирование новостей”
Редактирование списка новостей

1. Редактирование-Редактирование новости
2. Удалить - Удаление новости
3. Добавить - Добавить новость.
4. Дата - Дата новости. Данная дата будет выделена жирным "цветом"
5. Новость - Список новостей. Использование тегов html запрещено. При вставке тегов они будут рассматриваться как текст
6. № п/п - Номер по порядку от большего к меньшему. тем самым самые свежие новости всегда будут в начале перечня.
7. Сколько пунктов показать при предварительном показе - Сколько пунктов новостей показать при предварительном показе.

Вставка блока предварительного просмотра новостей производится с помощью JavaScript. Блок:
<script language="JavaScript" src="cgi-bin/inform.cgi?status=news"></script> Количество пунктов регулируется в поле "Сколько пунктов показать при предварительном показе" см. №7


1.8. “Редактирование новостей::Редактирование”
Редактирование новости

1. Дата новости -Дата новости. Формат даты сервера представлен. Для изменения формата даты см. 1.2. “Настройка”
2. Новость - Сама новость.


1.9. “Список прайсов”
Редактирование прайсав

1. Редактирование - Редактирование прайса
2. Удалить - Удалить прайс
3. Добавить - Добавить прайс
4. Дата - Дата поступления прайса
5. Наименование - Наименование прайса. Данное наименование будет видно в списке прайсов для посетителей
6. № п/п - Номер по порядку. От большего к меньшему.

Для вставки списка прайсов:
<script language="JavaScript" src="cgi-bin/inform.cgi?status=price"></script>


1.10. “Список прайсов::Редактирование”
Редактирование прайса

1. Удалить - Удалить файл
2. Дата/время - Дата и время поступления файла с прайсом
3. Размер - Размер файла в байтах
4. Имя файла - Имя файла
5. № п/п - Номер по порядку. От большего к меньшему.
6. Путь - Локальный путь и имя файла который необходимо загрузить на сервер. Для удобства пользуйтесь кнопочкой с диалоговым окном для выбора файла (кнопочка "Обзор")
7. Наименование прайса - Для изменения наименования прайса изменить данное поле и сохраните (кнопочка "Ввод")

Пользуйтесь навигацией (выделено красным цветом) для быстрого перехода.


1.11. “Редактирование расписания”
Редактирование групп расписания

1. Редактирование - Редактирование группы курсов
2. Удалить - Удалить группу
3. Добавить - Добавить новую группу
4. Количество курсов - Количество курсов в группе
5. Код - Код группы
6. Наименование группы курса - Наименование группы курса
7. № п/п - Номер по порядку. От большего к меньшему.
Вставка блока курсов:
<script language="JavaScript" src="cgi-bin/inform.cgi?status=kurs"></script>

Пользуйтесь навигацией (выделено красным цветом) для быстрого перехода.


1.12. “Группы::Курсы”
Редактирование группы расписания и списка курсов

1. Наименование группы курсов - Наименование группы курсов
2. Код - Код группы курсов
Для сохранения полей группы курса используйте кнопочку "Ввод"

3. Редактирование - Редактирование курса
4. Удалить - Удалить курс
5. Добавить - Добавить новый курс
6. Код - Код курса
7. Стоимость- Стоимость курса (валюта может быть произвольной)
8. Время - Время начала и окончания курса
9. Начало - Дата начала курса
10. Наименование - Наименование курса
11. № п/п - Номер по порядку. От большего к меньшему.


[ <<Назад ] [ в оглавление ] [Далее>>]

1.13. “Группы::Курсы::Редактирование”
Редактирование курса

1. Наименование курса - Наименование курса
2. Код - Код курса
3. Дата начала курса - Дата начала курса. Маска даты см. 1.2. "Настройка"
4. Время - Время начала и окончания курса
5. Стоимость - Стоимость курса. Укажите валюту.