описание

Описание сервера "Дистанционного обучения" ver 1.01

Назначение сервера - производить обучение "учащихся" по удаленной схеме с использованием internet технологии (web). Обучение на сервере дистанционного обучения (далее ДО) происходит по данной схеме:

Оглавление:

1. Описание функций и принципа работы сервера “Дистанционного обучения”
2.Рабочее место администратора сервера
 | 2.1. "Пароль"
 | 2.2. “Настройка”
 | 2.3. “Настройка акселерации”
 | 2.4. “Редактировать шаблоны”
 | 2.5. “Редактировать шаблоны ::Редактировать”
 | 2.6. “Перечень курсов”
 | 2.7. “Перечень курсов::Редактирование”
 | 2.8. “Редактирование новостей”
 | 2.9. “Редактирование новостей::Редактирование”
 | 2.10. “Библиотека”
 | 2.11. “Библиотека::Редактирование”
 | 2.12. “Преподаватели”
 | 2.13. “Преподаватели::Редактировать”
 | 2.14. “Преподаватели::Уведомление о регистрации”
 | 2.15. “Темы и уроки::Список тем”
 | 2.16. “Темы и уроки::Список тем::Уроки”
 | 2.17. “Темы и уроки::Список тем::Уроки::Редактирование”
 | 2.18. “Группы”
 | 2.19. “Группы::Ученики”
 | 2.20. “Группы::Ученики::Редактировать”
 | 2.21. “Группы::Ученики::Уведомление о регистрации”
3.Рабочее место преподавателя
 | 3.1. “Пароль доступа::Преподаватель”
 | 3.2. “Настройка”
 | 3.3. “Темы и уроки::Список тем”
 | 3.4. “Темы и уроки::Список тем::Уроки”
 | 3.5. “Темы и уроки::Список тем::Уроки::Редактирование”
 | 3.6. “Группы”
 | 3.7. “Группы::Ученики”
 | 3.8. “Группы::Ученики::Редактировать”
 | 3.9. “Группы::Ученики::Уведомление о регистрации”
4.Рабочее место ученика
 | 4.1. “Пароль доступа::Ученик”
 | 4.2. “Настройка”
 | 4.3. “Темы и уроки”
 | 4.4. “Темы и уроки::Список”
 | 4.5. “Обратная связь”


2.1. "Пароль" - настройка пароля на доступ
В данном разделе вы имеете возможность изменить пароль на доступ (для администратора)
1. Текущий логин администратора
2. Текущий пароль администратора
3. Новый логин администратора
4. Новый пароль администратора
5. Повтор нового пароля администратора


2.2. “Настройка”

Настройка окружения сервера
Таблица обозначения форматов даты и времени
d | - показывает день в виде числа без предшествующего нуля (значения 1-31)
dd | - показывает день в виде числа c предшествующим нулем (значения 01-31)
ddd | - показывает день недели в сокращенном виде (воскр-суб)
dddd | - показывает день недели в полном виде (воскресенье-суббота)
m | - показывает месяц в виде числа без предшествующего нуля (значения 1-12)
mm | - показывает месяц в виде числа c предшествующим нулем (значения 01-12)
mmm | - показывает месяц в сокращенном виде (янв-дек)
mmmm | - показывает месяц в полном виде (январь-декабрь)
yy | - показывает год в виде числа из двух цифр (значения 00-99)
yyyy | - показывает год в виде числа из четырех цифр (значения 0000-9999)
h | - показывает время в часах без предшествующего нуля (значения 0-23)
hh | - показывает время в часах с предшествующим нулем (значения 00-23)
n | - показывает минуты без предшествующего нуля (значения 0-59)
nn | - показывает минуты с предшествующим нулем (значения 00-59)
s | - показывает секунды без предшествующего нуля (значения 0-59)
ss | - показывает секунды с предшествующим нулем (значения 00-59)

1. Относительный путь до html шаблонов
2. Сетевой путь до сервера (не до шлюза)
3. Web администратора сервера или фирмы-владельца -Данный адрес автоматически вставляется в сноски страницы.
4. E-mail адрес администратора сервера - Данный адрес используется при вызове обратной связи и автоматически вставляется в сноски страницы
5. SMTP адрес - адрес SMTP сервер вашего (см. пункт №4) e-mail
6. Номер порта e-mail сервера - номер порта SMTP сервера вашего (см. пункт №4) e-mail
7. Перекодировка имен файлов для скачивания. Зависит от используемого IIS или PWS - Дело в том что при передаче данных различные версии веб серверов используют различные кодировки, дабы не возникли конфликты с кодировкой передаваемых имен предоставляемых материалов используется приведение к общей кодировке (WIN), необходимо указать из какой кодировки перекодировать. Для IIS4,5 - "DosToWin", для PWS - "не перекодировать"
8. Приоритет выполнения сервера - Для коррекции скорости работы сервера предусмотрена сетка привелений выполнения.
9. Формат "короткого" обозначения даты - обозначение короткого формата даты. Используется для обозначения даты. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
10. Формат "короткого" обозначения даты - обозначение короткого формата даты. Используется для обозначения даты на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
11. Разделитель времени - символ разделителя времени. К примеру - 12:12 символ ":" является разделителем.
12. Разделитель даты - символ разделителя даты. К примеру - 12.10.2001 символ "." является разделителем.
13. Формат "короткого" времени - обозначение короткого формата времени. Используется для обозначения времени на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"
15. Формат "длинного" времени - обозначение длинного формата времени. Используется для обозначения времени на сервера. Формат обозначения см. из таблице "Таблица обозначения форматов даты и времени"


2.3. “Настройка акселерации”

Настройка движка акселерации сервера

1. Упаковывать показываемые страницы стандартом GZip - Включить упаковку стандартом GZip Encoding. Увеличение скорость загрузки страниц от 2 до 16 раз (в некоторых случаях и до 20(!!) раз)
2. Удалять начальные пробелы в файлах html. - Очищает html от ненужных символов (первых пробелов) которые остаются от редактора html файлов. Уменьшение размера страницы от 5 до 40%.
3. Командная строка упаковки. - Вы имеете возможность самостоятельно настроить командную строку упаковки. Оптимальный вариант (скорость/процент упаковки) w3, Максимальная упаковка w9 но очень медленная, авто определение метода упаковки - w


2.4. “Редактировать шаблоны”

Интерактивное редактирование html шаблонов

1. Шаблоны для всех (общие) - список общих шаблонов.
2. Шаблоны для администратора - список шаблонов для администратора.
3. Шаблоны для преподавателя - список шаблонов для преподавателя
4. Шаблоны для ученика - список шаблонов для ученика.

От создателя шлюза: Как говорилось позже вся система (сервер) построен на шаблонной схеме - это значит что каждая страница представлена в виде шаблона (html страницы с специальными врезками) который динамически погружается, изменяется и "показывается" посетителю. В шаблонной технологии очень просто изменить дизайн любого шаблона (страницы) сервера не изменяя сам код шлюза. Однако для изменения шаблонов необходимо знать основы html языка и знать структуру сервера и бегло ориентироваться в спец тегах сервера. Для создания своего дизайна сервер обратитесь к профессионалам или фирме поставившего данный сервер. www.newtone.kz


2.5. “Редактировать шаблоны ::Редактировать”

Редактирование шаблона

1. Имя файла - Имя редактируемого файла
2. Размер файла - размер редактируемого файла. В байтах
3. Текст шаблона

От создателя шлюза: Для изменения шаблоны скопируйте в буфер содержимое текста шаблона в редактор html (к примеру FrontPage). Посте изменения новый текст через буфер обмена скопируйте в текст шаблона и сохраните (кнопочка "Сохранить").


2.6. “Перечень курсов”

Редактирование перечня курсов

1. Редактирование курса - В редактировании курса вы можете изменить : № курса, Наименование курса, Цену.
2. Удалить - удалить курс.
3. Добавить - Добавить новый курс.

Для вставки списка курсов используйте строку вставки JavaScript
<script language="JavaScript" src="cgi-bin/ido.cgi?status=Course"></script>
4. Курс - перечень курсов в базе данных.
5. № курса - у каждого курса имеется номер который распределяет учебное заведение
6. №-номер по порядку от большего к меньшему.
7. Цена - цена курса.


2.7. “Перечень курсов::Редактирование”

Редактирование курса

1. № курса - у каждого курса имеется номер который распределяет учебное заведение
2. Наименование - Наименование курса
3. Добавить - Добавить новый курс.


2.8. “Редактирование новостей”

Редактирование списка новостей

1. Редактирование-Редактирование новости
2. Удалить - Удаление новости
3. Добавить - Добавить новость.
4. Дата - Дата новости. Данная дата будет выделена жирным "цветом"
5. Новость - Список новостей. Использование тегов html запрещено. При вставке тегов они будут рассматриваться как текст
6. № п/п - Номер по порядку от большего к меньшему. тем самым самые свежие новости всегда будут в начале перечня.
7. Сколько пунктов показать при предварительном показе - Сколько пунктов новостей показать при предварительном показе.

Вставка блока предварительного просмотра новостей производится с помощью JavaScript. Блок:
<script language="JavaScript" src="cgi-bin/ido.cgi?status=news"></script> Количество пунктов регулируется в поле "Сколько пунктов показать при предварительном показе" см. №7


2.9. “Редактирование новостей::Редактирование”

Редактирование новости

1. Дата новости -Дата новости. Формат даты сервера представлен. Для изменения формата даты см. 2.2. “Настройка”
2. Новость - Сама новость.


2.10. “Библиотека”

Редактирование списка книг в библиотеке

1. Редактировать - Редактировать пункт в библиотеке
2. Удалить - Удалить "книгу" из списка.
3. Добавить - Добавить книгу в список книг.
4. Дата - Дата поступления книги в библиотеку
5. Ссылка и наименование книги - Наименование и сетевая ссылка к файлу (архиву) книги.
6. № п/п-Номер книги по порядку от большего к меньшему. Тем самым самые "свежие" книги будут в начале списка.

Вставка списка книг (вставка библиотеки) производится при помощи JavaScript. Блок:
<script language="JavaScript" src="cgi-bin/ido.cgi?status=bibleo"></script>


2.11. “Библиотека::Редактирование”

Редактирование пункта в библиотеке

1. Дата - Дата поступления книги в библиотеку. Формат даты указан. Для изменения формата даты см. 2.2. “Настройка”
2. Наименование - Наименование книги.
3. Ссылка - сетевая сслыка (не забудьте ввести полный формат пути "http://www.server.com/dir/file") Сетевой путь сделан дабы не загружать сервер промежуточной работой.


2.12. “Преподаватели”

Редактирование списка преподавателей

1. Редактировать - Редактировать учетную запись преподавателя
2. Удалить - Удалить учетную запись преподавателя
3. Добавить - Добавить новую учетную запись преподавателя. При добавлении новой учетной записи автоматически генерируется пароль и логин.
4. Количество тем - Количество тем доступных для курирования преподавателем
5. Ф.И.О. - Ф.И.О. преподавателя
6. № п/п - Номер по порядку. От большего к меньшему, тем самым самые новые учетные записи всегда в начале списка.


2.13. “Преподаватели::Редактировать ”

Редактирование учетной записи преподавателя

1. Фамилия - Фамилия преподавателя
2. Имя - Имя преподавателя
3. Отчество - Отчество преподавателя.
4. E-mail адрес - email адрес преподавателя.
5. Логин - Логин преподавателя. При добавлении новой учетной записи логин генерируется автоматически. 8 позиций, диапазон 1..9, A..Z, a..z. Процент совпадения паролей 1 к 13537086546263552
6. Пароль - Пароль преподавателя. При добавлении новой учетной записи пароль генерируется автоматически. 8 позиций, диапазон 1..9, A..Z, a..z. Процент совпадения паролей 1 к 13537086546263552
7. Тема - Список тем для курирования. Для разрешения курирования необходимой темы, выделите галочкой.
8. Количество уроков - Количество уроков в темах.
9. Отправить уведомление о регистрации - Раздел для отправления уведомления о регистрации преподавателя.

Используйте навигацию (выделенный блок) для быстрого перехода между преподавателями.


2.14. “Преподаватели::Уведомление о регистрации”

Отправка уведомления о регистрации преподавателю

1. Email преподавателя - Email адрес куда будет отправлено письмо.
2. Письмо - Письмо которое будет отправлено преподавателю. В данное письмо можно дописывать текст.

Используйте навигацию (выделено красным цветом) для быстрого перехода.


2.15. “Темы и уроки::Список тем”

Редактирование тем

1. Редактировать - Редактировать тему и список уроков
2. Удалить - Удалить тему. Удаляемая тема должна быть пустой.
3. Добавить - Добавить новую тему.
4. Количество уроков - Количество уроков в теме.
5. Наименование - Наименование темы
6. № п/п - Номер по порядку от большего к меньшему, тем самым самые новые темы всегда в начале списка.


2.16. “Темы и уроки::Список тем::Уроки”

Редактирование темы

1. Наименование темы - Наименование темы. Для изменения наименования темы измените данное поле и сохраните.
2. Редактировать - Редактировать наименование урока. В этом же разделе вы можете добавить материал (файлы произвольного формата).
3. Удалить - Удалить урок. При удалении урока материал тоже автоматически удаляется.
4. Добавить - Добавить новый урок
5. Уроки - Список уроков.
6. № п/п - Номер по порядку. От большего к меньшему.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


2.17. “Темы и уроки::Список тем::Уроки::Редактирование”

Редактирование урока

1. Наименование урока - Наименование урока. Для изменения наименования измените данное поле и сохраните "Ввод".
2. Удалить - Удалить материал (файл). Для добавления см. №7
3. Дата/Время - Дата и время добавления файла (материала).
4. Размер - Размер файла (в байтах)
5. Имя - Список имен файлов. Для просмотра содержимого файла перейдите на ссылку (само имя файла).
6. № п/п - Номер по порядку. От большего к меньшему.
7. Путь - Для добавления файла укажите путь и имя файла который необходимо добавить. Воспользуйтесь кнопочкой "Обзор" для выбора файла из диалогового окна. После указания пути и имени файла передайте его на сервер (кнопочка "Загрузить")

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


2.18. “Группы”

Редактирование групп учеников

Схема построения базы учеников такова:
1. Группы
2. Ученики
3. Разрешение на доступ к урокам

1. Редактировать - Редактировать группу учеников
2. Удалить - Удалить группу учеников. Для удаления группа должна быть пустой.
3. Добавление - Добавление новой группы
4. Количество учеников - Количество учеников в группе
5. Наименование - Наименование групп.
6. № п/п - Номер по порядку. От большего к меньшему.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


2.19. “Группы::Ученики”

Редактирование списка учеников

1. Наименование - Наименование группы. Для изменения названия измените данное поле и сохраните (кнопочка "ввод")
2. Редактирование - редактирование учетной записи ученика.
3. Удалить - Удалить учетную запись ученика.
4. Добавить - Добавить новую учетную запись ученика. Логин и пароль генерируется автоматически.
5. Количество тем - Количество тем разрешенных для ученика.
6. Ф.И.О. - Ф.И.О. ученика.
7. № п/п - Номер по порядку. От большего к меньшему.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


2.20. “Группы::Ученики::Редактировать”

Редактирование учетной записи ученика

1. Фамилия - Фамилия ученика
2. Имя - Имя ученика
3. Отчество - Отчество ученика
4. E-Mail адрес - E-Mail адрес ученика.
5. Логин - Логин ученика. При добавлении новой учетной записи логин генерируется автоматически. 8 позиций, диапазон 1..9, A..Z, a..z. Процент совпадения паролей 1 к 13537086546263552
6. Пароль - Пароль ученика. При добавлении новой учетной записи пароль генерируется автоматически. 8 позиций, диапазон 1..9, A..Z, a..z. Процент совпадения паролей 1 к 13537086546263552
7. Тема и список уроков - Для разрешения урока отметьте галочкой урок и сохраните (кнопочка "ввод")
8. Отправить уведомление о регистрации - Отправка уведомления о регистрации на e-mail ученику.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


2.21. “Группы::Ученики::Уведомление о регистрации”

Письмо - уведомление о регистрации ученика

1. E-mail ученика - E-mail ученика на который будет отправлено письмо.
2. Текст - Текст письма. Редактирование разрешено.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


3.1. “Пароль доступа::Преподаватель”

В данном разделе вы имеете возможность изменить пароль на доступ (для преподавателя)

1. Текущий логин преподавателя
2. Текущий пароль преподавателя
3. Новый логин преподавателя
4. Новый пароль преподавателя
5. Повтор нового пароля преподавателя


3.2. “Настройка”

Изменение личных данных преподавателя

1. Фамилия - Фамилия преподавателя
2. Имя - Имя преподавателя
3. Отчество - Отчество преподавателя
4. E-Mail адрес - E-Mail адрес преподавателя


3.3. “Темы и уроки::Список тем”

Редактирование тем

В данное секции показаны только темы которые разрешены текущему преподавателю.

1. Редактировать - Редактировать тему
2. Количество уроков - Количество уроков в теме.
3. Наименование - Наименование темы
4. № п/п - Номер по порядку от большего к меньшему, тем самым самые новые темы всегда в начале списка.


3.4. “Темы и уроки::Список тем::Уроки”

Редактирование темы

1. Наименование темы - Наименование темы. Для изменения названия темы измените данное поле и сохраните (кнопочка "Ввод")
2. Редактирование - Редактирование урока
3. Уроки - Наименование уроков.
4. № п/п - Номер по порядку от большего к меньшему, тем самым самые новые темы всегда в начале списка.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


3.5. “Темы и уроки::Список тем::Уроки::Редактирование”

Редактирование урока

1. Наименование урока - Наименование урока. Для изменения названия урока измените данное поле и сохраните (кнопочка "Ввод")
2. Удалить - Удалить файл с материалом
3. Дата/Время - Дата и время поступления файла.
4. Размер - Размер файла в байтах
5. Имя - Список имен файлов. Для просмотра содержимого файла перейдите на ссылку (само имя файла).
6. № п/п - Номер по порядку. От большего к меньшему.
7. Путь - Для добавления файла укажите путь и имя файла который необходимо добавить. Воспользуйтесь кнопочкой "Обзор" для выбора файла из диалогового окна. После указания пути и имени файла передайте его на сервер (кнопочка "Загрузить")

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


3.6. “Группы”

Редактирование групп учеников
Схема построения базы учеников такова:
1. Группы
2. Ученики
3. Разрешение на доступ к урокам
Для учителя список формируется только из тех учеников которые имеют доступ к материалам которые курирует учитель.

1. Редактировать - Редактировать группу учеников
2. Количество учеников - Количество учеников в группе
3. Наименование - Наименование групп.
4. № п/п - Номер по порядку. От большего к меньшему.


3.7. “Группы::Ученики”

Редактирование учеников
1. Наименование - Наименование группы. Для изменения названия измените данное поле и сохраните (кнопочка "ввод")
2. Редактирование - редактирование учетной записи ученика.
3. Количество тем - Количество тем разрешенных для ученика.
4. Ф.И.О. - Ф.И.О. ученика.
5. № п/п - Номер по порядку. От большего к меньшему.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


3.8. “Группы::Ученики::Редактировать”

Редактирование учеников
1. Фамилия - Фамилия ученика
2. Имя - Имя ученика
3. Отчество - Отчество ученика
4. E-Mail адрес - E-Mail адрес ученика.
5. Логин - Логин ученика. При добавлении новой учетной записи логин генерируется автоматически. 8 позиций, диапазон 1..9, A..Z, a..z. Процент совпадения паролей 1 к 13537086546263552
6. Пароль - Пароль ученика. При добавлении новой учетной записи пароль генерируется автоматически. 8 позиций, диапазон 1..9, A..Z, a..z. Процент совпадения паролей 1 к 13537086546263552
7. Тема и список уроков - Для разрешения урока отметьте галочкой урок и сохраните (кнопочка "ввод")
8. Отправить уведомление о регистрации - Отправка уведомления о регистрации на e-mail ученику.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


3.9. “Группы::Ученики::Уведомление о регистрации”

Письмо - уведомление о регистрации ученика
1. E-mail ученика - E-mail ученика на который будет отправлено письмо.
2. Текст - Текст письма. Редактирование разрешено.

Пользуйтесь навигацией (выделенный блок) для быстрого перехода.


4.1. “Пароль доступа::Ученик”

В данном разделе вы имеете возможность изменить пароль на доступ (для ученика)
1. Текущий логин ученика
2. Текущий пароль ученика
3. Новый логин ученика
4. Новый пароль ученика
5. Повтор нового пароля ученика


4.2. “Настройка”

Изменение личных данных ученика
1. Фамилия - Фамилия ученика
2. Имя - Имя ученика
3. Отчество - Отчество ученика
4. E-Mail адрес - E-Mail адрес ученика


4.3. “Темы и уроки”

Изменение личных данных ученика
1. Тема и список уроков - Список разрешенных для изучения уроков.


4.4. “Темы и уроки::Список”

Материал урока
1. Дата/Время - Дата и время поступления файла/материала
2. Размер - Размер файла в байтах
3. Имя файла - Имя файла с материалом
4. № п/п - Номер по порядку. От большего к меньшему.
5.Отправить письмо тьютеру - Если ученику необходимо задать вопрос преподавателю, он может воспользоваться данным разделом.


[ <<Назад ] [ в оглавление ] [Далее>>]

4.5. “Обратная связь”

Обратная связь
1. Заголовок письма - Заголовок письма для учителя
2. Текст - Текст письма для учителя


[<<Назад] [в оглавление ] [ Далее>> ]

Описание функций и принципа работы для сервера
Назначение сервера - производить обучение "учащихся" по удаленной схеме с использованием internet технологии (web). Обучение на сервере дистанционного обучения (далее ДО) происходит по данной схеме:
  1. Будущий учащийся изъявляет желание обучатся на определенном курсе ДО.
  2. Куратор выбранного курса вводит анкетные данные учащегося и отправляет идентификационные данные ученику.
  3. Ученик используя идентификационные данные получает доступ к материалу и изучает его.
  4. Куратор проверяет знание учащегося (с помощью тестирования. Сервер тестирования поставляется в комплекте).
  5. В случае сдачи тестирования куратор разрешает доступ к следующему уроку.

Форма контроля знания может быть и произвольной. (к примеру контроль по электронной почте)